summaryrefslogtreecommitdiffstats
path: root/kpoker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kpoker/CMakeLists.txt')
-rw-r--r--kpoker/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kpoker/CMakeLists.txt b/kpoker/CMakeLists.txt
new file mode 100644
index 00000000..9e339067
--- /dev/null
+++ b/kpoker/CMakeLists.txt
@@ -0,0 +1,42 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( sounds )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kpoker (executable) #######################
+
+tde_add_executable( kpoker AUTOMOC
+ SOURCES kpoker.cpp kpaint.cpp top.cpp main.cpp betbox.cpp optionsdlg.cpp
+ player.cpp playerbox.cpp newgamedlg.cpp poker.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kpoker )
+
+
+##### other data ################################
+
+install( FILES kpoker.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kpokerui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kpoker
+)