summaryrefslogtreecommitdiffstats
path: root/ktron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ktron/Makefile.am')
-rw-r--r--ktron/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/ktron/Makefile.am b/ktron/Makefile.am
new file mode 100644
index 00000000..e7629bd2
--- /dev/null
+++ b/ktron/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS=pics
+
+bin_PROGRAMS = ktron
+INCLUDES = -I$(top_srcdir)/libkdegames $(all_includes)
+
+ktron_SOURCES = ai.ui appearance.ui general.ui tron.cpp player.cpp ktron.cpp main.cpp settings.kcfgc
+ktron_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+ktron_LDADD = $(LIB_KIO) $(LIB_KDEGAMES)
+ktron_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+EXTRA_DIST = ktron.desktop
+
+xdg_apps_DATA = ktron.desktop
+kde_kcfg_DATA = ktron.kcfg
+
+METASOURCES = AUTO
+
+rcdir = $(kde_datadir)/ktron
+rc_DATA = ktronui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/ktron.pot