summaryrefslogtreecommitdiffstats
path: root/libkdegames/highscore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libkdegames/highscore/Makefile.am')
-rw-r--r--libkdegames/highscore/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/libkdegames/highscore/Makefile.am b/libkdegames/highscore/Makefile.am
new file mode 100644
index 00000000..6fa18cc0
--- /dev/null
+++ b/libkdegames/highscore/Makefile.am
@@ -0,0 +1,19 @@
+noinst_LTLIBRARIES = libkhighscore.la
+
+INCLUDES = $(all_includes)
+
+libkhighscore_la_SOURCES = kconfigrawbackend.cpp \
+ kfilelock.cpp khighscore.cpp kscoredialog.cpp \
+ kexthighscore_item.cpp kexthighscore_internal.cpp \
+ kexthighscore_tab.cpp kexthighscore_gui.cpp \
+ kexthighscore.cpp
+
+include_HEADERS = khighscore.h kscoredialog.h \
+ kexthighscore_item.h kexthighscore.h
+
+noinst_HEADERS = kconfigrawbackend.h \
+ kfilelock.h kexthighscore_internal.h kexthighscore_tab.h \
+ kexthighscore_gui.h
+
+METASOURCES = kconfigrawbackend.moc khighscore.moc kscoredialog.moc \
+ kexthighscore_tab.moc kexthighscore_gui.moc