summaryrefslogtreecommitdiffstats
path: root/libtdegames/carddecks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtdegames/carddecks/CMakeLists.txt')
-rw-r--r--libtdegames/carddecks/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/libtdegames/carddecks/CMakeLists.txt b/libtdegames/carddecks/CMakeLists.txt
index 102d0391..6b1bb7fb 100644
--- a/libtdegames/carddecks/CMakeLists.txt
+++ b/libtdegames/carddecks/CMakeLists.txt
@@ -14,4 +14,17 @@ install( DIRECTORY cards-aisleriot cards-dondorf-whist-b
cards-spaced cards-xskat-french cards-default decks
cards-konqi-modern cards-warwick cards-xskat-german
DESTINATION ${DATA_INSTALL_DIR}/carddecks
+ PATTERN *.desktop EXCLUDE
)
+
+file( GLOB_RECURSE _desktops
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/*.desktop )
+foreach( _desktop IN LISTS _desktops )
+ get_filename_component( _theme ${_desktop} PATH )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${DATA_INSTALL_DIR}/carddecks/${_theme}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/libtdegames-carddecks
+ )
+endforeach()