summaryrefslogtreecommitdiffstats
path: root/libtdegames/kgame/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtdegames/kgame/CMakeLists.txt')
-rw-r--r--libtdegames/kgame/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/libtdegames/kgame/CMakeLists.txt b/libtdegames/kgame/CMakeLists.txt
new file mode 100644
index 00000000..d15f8bf7
--- /dev/null
+++ b/libtdegames/kgame/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( dialogs )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kgame (static) ############################
+
+tde_add_library( kgame STATIC_PIC AUTOMOC
+ SOURCES kgame.cpp kplayer.cpp kgamenetwork.cpp kgameproperty.cpp
+ kgamemessage.cpp kgameio.cpp kgameprocess.cpp kgamechat.cpp
+ kgamepropertyhandler.cpp kgameerror.cpp kgamesequence.cpp
+ kmessageio.cpp kmessageserver.cpp kmessageclient.cpp
+
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kgame.h kplayer.h kgamenetwork.h kgameproperty.h kgamemessage.h
+ kgameio.h kgameprocess.h kgamepropertyarray.h
+ kgamepropertylist.h kgamechat.h kgamepropertyhandler.h
+ kgameerror.h kgamesequence.h kgameversion.h
+ kmessageio.h kmessageserver.h kmessageclient.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kgame
+)