summaryrefslogtreecommitdiffstats
path: root/q15/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'q15/src/CMakeLists.txt')
-rw-r--r--q15/src/CMakeLists.txt47
1 files changed, 21 insertions, 26 deletions
diff --git a/q15/src/CMakeLists.txt b/q15/src/CMakeLists.txt
index d9228b93..9a71c1fd 100644
--- a/q15/src/CMakeLists.txt
+++ b/q15/src/CMakeLists.txt
@@ -1,15 +1,15 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-# (C) 2011-2012 Timothy Pearson
-# kb9vqf (AT) pearsoncomputing (DOT) net
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
+############################################
+# #
+# (C) 2010-2011 Serghei Amelian #
+# serghei (DOT) amelian (AT) gmail.com #
+# (C) 2011-2012 Timothy Pearson #
+# kb9vqf (AT) pearsoncomputing (DOT) net #
+# #
+# Improvements and feedback are welcome #
+# #
+# This file is released under GPL >= 2 #
+# #
+############################################
include_directories(
${CMAKE_BINARY_DIR}
@@ -24,21 +24,16 @@ link_directories(
)
-##### q15 #################################
+##### (executable) q15
-install( PROGRAMS
- ${CMAKE_CURRENT_BINARY_DIR}/q15
- DESTINATION ${BIN_INSTALL_DIR} )
+tde_add_executable( q15 AUTOMOC
-
-set( target q15 )
-
-set( ${target}_SRCS
- gameboard.cpp main.cpp mainwindow.cpp
-)
-
-tde_add_executable( ${target} AUTOMOC
- SOURCES ${${target}_SRCS}
- LINK tqt-mt
+ SOURCES
+ gameboard.cpp
+ main.cpp
+ mainwindow.cpp
+ LINK
+ tqt-mt
+
DESTINATION ${BIN_INSTALL_DIR}
)