summaryrefslogtreecommitdiffstats
path: root/kdvi/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /kdvi/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kdvi/CMakeLists.txt')
-rw-r--r--kdvi/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/kdvi/CMakeLists.txt b/kdvi/CMakeLists.txt
index 9c1ef8da..0b38628c 100644
--- a/kdvi/CMakeLists.txt
+++ b/kdvi/CMakeLists.txt
@@ -28,13 +28,16 @@ link_directories(
#### other data #################################
-install( FILES
- kdvi.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kdvi.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kdvi-desktops
+)
-install( FILES
- kdvimultipage.desktop
- DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kdvimultipage.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kdvi-desktops
+)
install( FILES
kdvi.kcfg