summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-28 15:10:59 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-29 11:36:46 +0200
commit0fe1e76bf078a1ce4fc8e32328038c9ada060f66 (patch)
tree44b3c87e397cf34b063153e5dfcd1e671235509a /CMakeLists.txt
parent2d89981f97e8b0e18b5b714800a9a7892dbe8fae (diff)
downloadtdeio-gopher-0fe1e76bf078a1ce4fc8e32328038c9ada060f66.tar.gz
tdeio-gopher-0fe1e76bf078a1ce4fc8e32328038c9ada060f66.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 328e9bf..a581546 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ cmake_minimum_required( VERSION 2.8.12 )
##### general package setup #####################
-project( tdeio-gopher )
+project( tdeio_gopher )
##### include essential cmake modules ###########
@@ -55,9 +55,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings #################
-add_definitions(
- -DHAVE_CONFIG_H
-)
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
@@ -67,8 +65,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### source directories ########################
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files #####################