summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-08-26 00:18:56 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-08-26 00:18:56 +0900
commita18f9fcc94b6982fecb8b75ccb5c21b213e78706 (patch)
treedb1e3d87eaba2952829717f25a51e9b7a5c18d8c /CMakeLists.txt
parent3eaf665507fb178a718ef9f57f2bb9ec908d5ac8 (diff)
downloadtdeio-gopher-a18f9fcc94b6982fecb8b75ccb5c21b213e78706.tar.gz
tdeio-gopher-a18f9fcc94b6982fecb8b75ccb5c21b213e78706.zip
Adapted to TDE and TQt3. Build and work fine. No helpbook or
translation are built yet. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt75
1 files changed, 61 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 988251f..f1bbd30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,22 +1,69 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
-find_package(KDE4 REQUIRED)
-include(KDE4Defaults)
-add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
-include_directories(${KDE4_INCLUDES})
+cmake_minimum_required( VERSION 2.8 )
-add_subdirectory(doc)
-set(tdeio_man_PART_SRCS tdeio_gopher.cpp)
+##### general package setup #####################
-kde4_add_plugin(tdeio_gopher ${tdeio_man_PART_SRCS})
+project( tdeio-gopher )
-target_link_libraries(tdeio_gopher ${KDE4_TDEIO_LIBS})
-install(TARGETS tdeio_gopher DESTINATION ${PLUGIN_INSTALL_DIR})
+##### include essential cmake modules ###########
-install(FILES gopher.protocol DESTINATION ${SERVICES_INSTALL_DIR})
+include( CheckCXXSourceCompiles )
+include( CheckFunctionExists )
+include( CheckIncludeFileCXX )
+include( CheckLibraryExists )
+include( CheckStructHasMember )
+include( CheckSymbolExists )
+include( CheckTypeSize )
+include( FindPkgConfig )
-find_package(Msgfmt REQUIRED)
-find_package(Gettext REQUIRED)
-add_subdirectory( po )
-add_subdirectory( doc-translations )
+
+##### include our cmake modules #################
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths #######################
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### configure checks ##########################
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings #################
+
+add_definitions(
+ -DHAVE_CONFIG_H
+)
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+
+
+##### source directories ########################
+
+add_subdirectory( src )
+#tde_conditional_add_subdirectory( BUILD_DOC doc )
+#tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+
+
+##### write configure files #####################
+
+configure_file( config.h.cmake config.h @ONLY )