summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-08-27 15:01:57 +0200
committerSlávek Banko <slavek.banko@axis.cz>2022-08-27 16:50:26 +0200
commitbabbfefe8b285343b4a4e4e5f6ba682f64650f50 (patch)
treed0ba0f8605356fbd77123c56d8e3071ab5af26b6 /src/CMakeLists.txt
parentae6f6c975fcaf2fed893b0a6bfefd3bf528d4ca6 (diff)
downloadtdeio-locate-babbfefe8b285343b4a4e4e5f6ba682f64650f50.tar.gz
tdeio-locate-babbfefe8b285343b4a4e4e5f6ba682f64650f50.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 71d3dec76ce1160a038dfbdac339fc6c349e8578)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0e58011..7943241 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,10 +25,17 @@ link_directories(
##### other data ################################
-install( FILES locate.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES locater.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES rlocate.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES locate.desktop DESTINATION ${SERVICES_INSTALL_DIR}/searchproviders )
+tde_create_translated_desktop(
+ SOURCE
+ locate.protocol
+ locater.protocol
+ rlocate.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+tde_create_translated_desktop(
+ SOURCE locate.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/searchproviders
+)
##### tdeio_locate ##############################