summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..6677503
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,46 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/kio/kio
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES locate.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES locater.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES rlocate.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES locate.desktop DESTINATION ${SERVICES_INSTALL_DIR}/searchproviders )
+
+
+##### kbzip2filter ##############################
+
+set( target kio_locate )
+
+set( ${target}_SRCS
+ klocateconfig.kcfgc klocateconfigwidget.ui klocateconfigfilterwidget.ui
+ klocateconfiglocatewidget.ui kio_locate.cpp locater.cpp pattern.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+) \ No newline at end of file