summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <obache@wizdas.com>2020-08-28 16:08:41 +0900
committerSlávek Banko <slavek.banko@axis.cz>2020-08-31 11:52:50 +0200
commitbde317d2cd53eac0e4274257f4e5e8f718e32fd6 (patch)
treef3fa4b53add50109e21170a50ead8eb53c69cef2 /CMakeLists.txt
parentf17a911197bdfc46089418ddae00f35ada87b314 (diff)
downloadtdelibs-bde317d2cd53eac0e4274257f4e5e8f718e32fd6.tar.gz
tdelibs-bde317d2cd53eac0e4274257f4e5e8f718e32fd6.zip
Add support of posix_openpt(2) to open master pseudo terminal device
Signed-off-by: OBATA Akio <obache@wizdas.com> (cherry picked from commit 8e542575e044baf23ae636d32f1c6d4e3b8dea18)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a0d9a02f0..04754eb00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -418,6 +418,7 @@ check_function_exists( strcasecmp HAVE_STRCASECMP )
check_function_exists( strchr HAVE_STRCHR )
check_function_exists( strcmp HAVE_STRCMP )
check_function_exists( strrchr HAVE_STRRCHR )
+check_function_exists( posix_openpt HAVE_POSIX_OPENPT )
check_function_exists( ptsname HAVE_PTSNAME )
check_function_exists( unlockpt HAVE_UNLOCKPT )
check_function_exists( _getpty HAVE__GETPTY )