summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-03-07 22:21:31 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-03-07 22:21:31 -0600
commit06227c5420ce8eeef7bd44406a395188c61e1703 (patch)
treec18c25b31413479e63fec92f61067b95759fc3b0 /CMakeLists.txt
parentce5d3d7fd554b9832a69350cffa8d79c5002753e (diff)
parent70d7c59d2ac9ad3718f92a20c07937d3b6cfb928 (diff)
downloadtdelibs-06227c5420ce8eeef7bd44406a395188c61e1703.tar.gz
tdelibs-06227c5420ce8eeef7bd44406a395188c61e1703.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47d5b258b..113c618c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,9 +62,9 @@ add_custom_target(install-apidox
OPTION( WITH_ALL_OPTIONS "Enable all optional support" OFF )
-OPTION( KDE_MALLOC "Use own malloc implementation" OFF )
-OPTION( KDE_MALLOC_DEBUG "Enable debugging in fast malloc" OFF )
-OPTION( KDE_MALLOC_FULL "Make alloc as fast as possible" OFF )
+OPTION( TDE_MALLOC "Use own malloc implementation" OFF )
+OPTION( TDE_MALLOC_DEBUG "Enable debugging in fast malloc" OFF )
+OPTION( TDE_MALLOC_FULL "Make alloc as fast as possible" OFF )
OPTION( WITH_ARTS "Build with aRts" ON )
OPTION( WITH_ALSA "Enable ALSA support" ON )
@@ -97,12 +97,12 @@ set( ENV{PKG_CONFIG_PATH} "${PKG_CONFIG_PATH}:${PKGCONFIG_INSTALL_DIR}:${LIB_INS
### FIXME fast malloc is also available on x86_64 architecture?
if( ${CMAKE_SYSTEM_PROCESSOR} MATCHES "i?86" OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64" )
- set( KDE_MALLOC_X86 1 )
+ set( TDE_MALLOC_X86 1 )
message( STATUS "Found x86 architecture" )
else( ${CMAKE_SYSTEM_PROCESSOR} MATCHES "i?86" OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64" )
- if( KDE_MALLOC )
+ if( TDE_MALLOC )
message( FATAL_ERROR "\nKDE fast malloc is available only on x86 architecture" )
- endif( KDE_MALLOC )
+ endif( TDE_MALLOC )
endif( ${CMAKE_SYSTEM_PROCESSOR} MATCHES "i?86" OR ${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64" )