summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-11 16:43:23 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-11 16:43:23 +0000
commit0ba4e3c0a468d0ce3d64c4062a39e8a792b29b93 (patch)
tree2345621c7578cf29abe594a39c486409f01a7281 /CMakeLists.txt
parent10308be19ef7fa44699562cc75946e7ea1fdf6b9 (diff)
downloadtdelibs-0ba4e3c0a468d0ce3d64c4062a39e8a792b29b93.tar.gz
tdelibs-0ba4e3c0a468d0ce3d64c4062a39e8a792b29b93.zip
[kdelibs] move "-include tqt.h" directive to CMAKE_CXX_FLAGS; move TQT_CFLAGS_OTHER definitions to main CMakeLists.txt; remove useless defintions
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1213800 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69a7169be..33eb77959 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ include( CheckIncludeFile )
include( CheckSymbolExists )
include( CheckFunctionExists )
include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
include( CheckTypeSize )
include( CheckCSourceRuns )
include( CheckLibraryExists )
@@ -747,11 +748,7 @@ set( KDE3_KCFGC_EXECUTABLE ${CMAKE_BINARY_DIR}/kdecore/kconfig_compiler/kconfig_
add_definitions(
-DHAVE_CONFIG_H
- -DQT_NO_ASCII_CAST
- -DQT_CLEAN_NAMESPACE
- -DQT_NO_STL
- -DQT_NO_COMPAT
- -DQT_NO_TRANSLATION
+ ${TQT_CFLAGS_OTHER}
)
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -include tqt.h" )