summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-02-14 16:37:29 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-02-15 11:03:55 +0900
commitd81ab9bb5c7fa43eadc3f6cee929602c162b8107 (patch)
tree8eab132a999ad1a734a765043c8781438785652e /CMakeLists.txt
parent5e51787f9af4fd86450fab9e787b4037a772bca3 (diff)
downloadtdelibs-d81ab9bb5c7fa43eadc3f6cee929602c162b8107.tar.gz
tdelibs-d81ab9bb5c7fa43eadc3f6cee929602c162b8107.zip
Simplify code since cmake minimum version is now 3.5
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 3fef2883847ae38f1b55e9a1d09f1a908a81f4b1)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3fd6f294..ed2b99b96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,14 +57,8 @@ list( APPEND TDECORE_LIBRARY_DIRS ${TQT_LIBRARY_DIRS} )
##### add apidox targets ############
-if( "${CMAKE_VERSION}" VERSION_LESS "3.1" )
- set( CMAKE_ENV "env" )
-else()
- set( CMAKE_ENV "${CMAKE_COMMAND};-E;env" )
-endif()
-
add_custom_target( apidox
- COMMAND ${CMAKE_ENV}
+ COMMAND ${CMAKE_COMMAND} -E env
"TQTDOCDIR=/usr/share/tqt3/doc/html"
${CMAKE_SOURCE_DIR}/admin/doxygen.sh
--no-modulename