summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-09 01:54:13 -0600
committerSlávek Banko <slavek.banko@axis.cz>2012-06-02 19:05:17 +0200
commit422f8fa037a1b8fadb6ec54da265025da7edaca2 (patch)
tree79eae49bd5407208635cc74571b96b2e5339617c /CMakeLists.txt
parentff8a72a22119c637f5e410ef58b1a667ee18cd62 (diff)
downloadtdelibs-422f8fa037a1b8fadb6ec54da265025da7edaca2.tar.gz
tdelibs-422f8fa037a1b8fadb6ec54da265025da7edaca2.zip
Add inotify CMake support to tdelibs
(cherry picked from commit 24f144faf98249012e7b1657a5dfe93750f0dfde)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17864c6cf..c8508c810 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,6 +76,7 @@ OPTION( WITH_OPENEXR "Enable openexr support" OFF )
OPTION( WITH_UTEMPTER "Use utempter for utmp management" OFF )
OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
+OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
OPTION( WITH_ASPELL "Enable aspell support" OFF )
OPTION( WITH_HSPELL "Enable hspell support" OFF )
@@ -726,6 +727,26 @@ if( WITH_PCRE )
set( HAVE_PCREPOSIX 1 )
endif( )
+##### check for inotify ###########################
+
+if( WITH_INOTIFY )
+ check_include_file( "inotify.h" INOTIFY_FOUND )
+ check_include_file( "sys/inotify.h" INOTIFY_SYS_FOUND )
+ if( NOT INOTIFY_FOUND )
+ if( NOT INOTIFY_SYS_FOUND )
+ message(FATAL_ERROR "\ninotify support was requested, but inotify was not found on your system" )
+ endif( NOT INOTIFY_SYS_FOUND )
+ endif( NOT INOTIFY_FOUND )
+ if( INOTIFY_FOUND )
+ set( HAVE_INOTIFY 1 )
+ endif( INOTIFY_FOUND )
+ if( INOTIFY_SYS_FOUND )
+ set( HAVE_INOTIFY 1 )
+ set( HAVE_SYS_INOTIFY 1 )
+ endif( INOTIFY_SYS_FOUND )
+endif( )
+
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too