summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-08-10 16:37:19 -0500
committerSlávek Banko <slavek.banko@axis.cz>2015-12-23 02:22:28 +0100
commit49035a61b38fa68c476c908acf99959b21c68d76 (patch)
treeca1e0c26134fcda48e9e3d5f29bd9c091ecae9c4 /CMakeLists.txt
parent0ffdced1e7d17e3b7fcf4adf5a0e27d5f3fdd2ac (diff)
downloadtdelibs-49035a61b38fa68c476c908acf99959b21c68d76.tar.gz
tdelibs-49035a61b38fa68c476c908acf99959b21c68d76.zip
Fix tdeioslaves FTBFS when compiled in standalone.
This resolves bug report 1617. Cmake doesn't define HAVE_BACKTRACE. This resolves bug report 1614. (cherry picked from commit 12976397880bd538311859d4fe5e1a473c326e5e)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb8c24b8a..43ef080e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -262,6 +262,7 @@ check_symbol_exists( gethostbyname2_r "netdb.h" HAVE_GETHOSTBYNAME2_R )
check_symbol_exists( gethostbyname_r "netdb.h" HAVE_GETHOSTBYNAME_R )
check_symbol_exists( gai_strerror "sys/types.h;sys/socket.h;netdb.h" HAVE_GAI_STRERROR )
check_symbol_exists( getaddrinfo "sys/types.h;sys/socket.h;netdb.h" HAVE_GETADDRINFO )
+check_symbol_exists( backtrace "execinfo.h" HAVE_BACKTRACE )
check_function_exists( usleep HAVE_USLEEP )
check_symbol_exists( usleep "unistd.h" HAVE_USLEEP_PROTO )