summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-06-02 01:52:19 +0200
committerSlávek Banko <slavek.banko@axis.cz>2017-07-22 15:56:54 +0200
commit69c87f5393ad97a59f66739de9ddc39a53396ca1 (patch)
tree80f4b620d377fdfcc225842de674d4d528f104b8 /CMakeLists.txt
parent88291f7e7f58fd3fc6c65de950c7ab9b2b76363f (diff)
downloadtdelibs-69c87f5393ad97a59f66739de9ddc39a53396ca1.tar.gz
tdelibs-69c87f5393ad97a59f66739de9ddc39a53396ca1.zip
Allow openssl detection without pkg-config file
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2aa548763e7d1dd7a10427df45988a78b3e97b8b)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adb957f06..3f0789e6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -886,7 +886,15 @@ endif( WITH_LIBBFD )
if( WITH_SSL )
pkg_search_module( SSL openssl )
if( NOT SSL_FOUND )
- message(FATAL_ERROR "\nSSL support are requested, but openssl is not found on your system" )
+ check_include_file( openssl/ssl.h HAVE_OPENSSL_H )
+ check_library_exists( ssl SSL_library_init "" HAVE_LIBSSL )
+ check_library_exists( crypto EVP_EncryptInit_ex "" HAVE_LIBCRYPTO )
+ if( HAVE_OPENSSL_H AND HAVE_LIBSSL AND HAVE_LIBCRYPTO )
+ set( SSL_FOUND 1 CACHE INTERNAL "" FORCE )
+ endif( HAVE_OPENSSL_H AND HAVE_LIBSSL AND HAVE_LIBCRYPTO )
+ endif( NOT SSL_FOUND )
+ if( NOT SSL_FOUND )
+ tde_message_fatal( "SSL support is requested, but openssl not found on your system" )
endif( NOT SSL_FOUND )
set( KSSL_HAVE_SSL 1 )
set( HAVE_SSL 1 )