summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-17 01:48:40 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-28 20:53:55 +0100
commit91931f112d5619a1c84ed901a1165b64b37dd2d1 (patch)
treef72335f62645393f37750d17679306514ffc46a4 /CMakeLists.txt
parent89bf82ed5e052733c20b20204c8dce2135d62284 (diff)
downloadtdelibs-91931f112d5619a1c84ed901a1165b64b37dd2d1.tar.gz
tdelibs-91931f112d5619a1c84ed901a1165b64b37dd2d1.zip
Use common GCC visibility test.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 83e4c4d56c1bda0a7b925c8dccb971d7a3a12362)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54726f505..54e080d5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -999,16 +999,9 @@ endif( )
##### check for gcc visibility support #########
-# FIXME
-# This should check for [T]Qt3 visibility support
if( WITH_GCC_VISIBILITY )
- if( NOT UNIX )
- message(FATAL_ERROR "\ngcc visibility support was requested, but your system is not *NIX" )
- endif( NOT UNIX )
- set( __KDE_HAVE_GCC_VISIBILITY 1 )
- set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden")
- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden")
+ tde_setup_gcc_visibility( )
endif( )