summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-08 03:07:46 -0600
committerSlávek Banko <slavek.banko@axis.cz>2012-06-02 19:05:09 +0200
commitc0dbbd249a685246475870fac20629c7d3f4b93c (patch)
treed40d0e636f207e718213f8b2659aefdf1bf6cbea /CMakeLists.txt
parent2d1297daca2df5b7608daf02d7d8c72e6e1785b1 (diff)
downloadtdelibs-c0dbbd249a685246475870fac20629c7d3f4b93c.tar.gz
tdelibs-c0dbbd249a685246475870fac20629c7d3f4b93c.zip
Add pcre detection to tdelibs CMake files
This closes Bug 569 (cherry picked from commit b911168351033cde8e3b524060722e0001c27bda)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 569129be7..17864c6cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,7 @@ OPTION( WITH_JASPER "Enable jasper (jpeg2k) support" OFF )
OPTION( WITH_OPENEXR "Enable openexr support" OFF )
OPTION( WITH_UTEMPTER "Use utempter for utmp management" OFF )
OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
+OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_ASPELL "Enable aspell support" OFF )
OPTION( WITH_HSPELL "Enable hspell support" OFF )
@@ -715,6 +716,16 @@ if( WITH_AVAHI )
endif( WITH_QT3 )
endif( )
+##### check for pcre ###########################
+
+if( WITH_PCRE )
+ pkg_search_module( LIBPCRE libpcre )
+ if( NOT LIBPCRE_FOUND )
+ message(FATAL_ERROR "\npcre support are requested, but not found on your system" )
+ endif( NOT LIBPCRE_FOUND )
+ set( HAVE_PCREPOSIX 1 )
+endif( )
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too