summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-28 19:57:16 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-28 20:55:45 +0100
commitc43ecb347b50170c0ee614512eb424dcce719c91 (patch)
treecaf408e0e86c4afaa51ca9f4de15b0c9c389c1db /CMakeLists.txt
parent91931f112d5619a1c84ed901a1165b64b37dd2d1 (diff)
downloadtdelibs-c43ecb347b50170c0ee614512eb424dcce719c91.tar.gz
tdelibs-c43ecb347b50170c0ee614512eb424dcce719c91.zip
Use common test for large files support.
Drop hardcoded definition -D_LARGEFILE64_SOURCE=1. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit ebf0115af1c52612e02fd8908b4240501bd34c60)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54e080d5f..5e1fbd83d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,6 +144,8 @@ endif( NO_BUILTIN )
include(TestBigEndian)
test_big_endian(WORDS_BIGENDIAN)
+tde_setup_largefiles( )
+
tde_save_and_set( CMAKE_REQUIRED_INCLUDES ${CMAKE_SOURCE_DIR}/libltdl )
check_include_file( "ltdl.h" HAVE_LTDL_H )
if( NOT HAVE_LTDL_H )