summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-01-30 22:53:06 +0100
committerSlávek Banko <slavek.banko@axis.cz>2017-07-22 15:56:52 +0200
commitcb041edbef5ae4894559ed9307968b7b1f4a8b07 (patch)
tree51fc950b0bf72189cfec0b4bfcd2c93c6826ba16 /CMakeLists.txt
parenteac0d388231c563984aff7aadf459cbdfd40e25d (diff)
downloadtdelibs-cb041edbef5ae4894559ed9307968b7b1f4a8b07.tar.gz
tdelibs-cb041edbef5ae4894559ed9307968b7b1f4a8b07.zip
Fix detection whether the system is big endian
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 7cc97cb18734939136579c086bf6758f3a4c18ad)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c176f370e..adb957f06 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,6 +141,9 @@ endif( NO_BUILTIN )
##### system checks #############################
+include(TestBigEndian)
+test_big_endian(WORDS_BIGENDIAN)
+
tde_save_and_set( CMAKE_REQUIRED_INCLUDES ${CMAKE_SOURCE_DIR}/libltdl )
check_include_file( "ltdl.h" HAVE_LTDL_H )
if( NOT HAVE_LTDL_H )