summaryrefslogtreecommitdiffstats
path: root/arts/knotify/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /arts/knotify/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'arts/knotify/Makefile.am')
-rw-r--r--arts/knotify/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/arts/knotify/Makefile.am b/arts/knotify/Makefile.am
new file mode 100644
index 000000000..bf743ce45
--- /dev/null
+++ b/arts/knotify/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES= -I$(top_srcdir)/arts/kde -I$(includedir)/arts $(all_includes)
+
+####### Files
+
+kde_module_LTLIBRARIES = knotify.la
+
+knotify_la_SOURCES = knotify.cpp knotify.skel
+if include_ARTS
+knotify_la_LIBADD = -lsoundserver_idl -lqtmcop $(LIB_KDEUI) $(top_builddir)/arts/kde/libartskde.la
+endif
+knotify_la_LDFLAGS = $(all_libraries) -module -avoid-version
+knotify_la_METASOURCES = AUTO
+
+check_PROGRAMS = knotifytest
+knotifytest_SOURCES = knotifytest.cpp
+knotifytest_LDADD = $(LIB_KDECORE)
+knotifytest_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+noinst_HEADERS = knotify.h
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = knotify.desktop
+
+messages:
+ $(XGETTEXT) knotify.cpp -o $(podir)/knotify.pot
+