summaryrefslogtreecommitdiffstats
path: root/dcop/dcopidl/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /dcop/dcopidl/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'dcop/dcopidl/Makefile.am')
-rw-r--r--dcop/dcopidl/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/dcop/dcopidl/Makefile.am b/dcop/dcopidl/Makefile.am
new file mode 100644
index 000000000..2b07f5e0a
--- /dev/null
+++ b/dcop/dcopidl/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES = $(all_includes)
+AM_LDFLAGS = $(all_libraries)
+AM_CPPFLAGS = -DYYDEBUG
+
+####### Files
+
+bin_PROGRAMS = dcopidl
+
+dcopidl_SOURCES = main.cpp yacc.cc scanner.cc
+noinst_HEADERS = yacc.cc.h
+
+dcopidl_LDADD = $(LIB_QT)
+dcopidl_LDFLAGS = $(KDE_RPATH) $(AM_LDFLAGS)
+
+####### Build rules
+
+parser:
+ cd $(srcdir) && flex -B -8 -oscanner.cc scanner.ll ;\
+ bison -t -d -v -o yacc.cc yacc.yy && mv yacc.hh yacc.cc.h
+
+check-local:
+ $(srcdir)/run_test.sh $(srcdir)
+
+EXTRA_DIST = dcopidl_test.h scanner.ll yacc.yy
+
+MAINTAINERCLEANFILES = yacc.cc.output