summaryrefslogtreecommitdiffstats
path: root/dcop/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-12-18 16:42:50 +0300
committerSlávek Banko <slavek.banko@axis.cz>2017-07-22 15:56:51 +0200
commit30c0e861094d0058ac589dddb2cf83bb32d09a83 (patch)
tree364c8af23ec9a10a35356ae3a07f2f1c16ab415d /dcop/tests/CMakeLists.txt
parent8e0f94f7d96306dcaeceee8561466665210c4000 (diff)
downloadtdelibs-30c0e861094d0058ac589dddb2cf83bb32d09a83.tar.gz
tdelibs-30c0e861094d0058ac589dddb2cf83bb32d09a83.zip
dcop/tests: run dcop tests in a safer manner
Signed-off-by: Alexander Golubev <fatzer2@gmail.com> (cherry picked from commit f2d8e88f099f908075d3d7b166fdb40d9be6c1c5)
Diffstat (limited to 'dcop/tests/CMakeLists.txt')
-rw-r--r--dcop/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/dcop/tests/CMakeLists.txt b/dcop/tests/CMakeLists.txt
index 3cdb3f7b4..4530db268 100644
--- a/dcop/tests/CMakeLists.txt
+++ b/dcop/tests/CMakeLists.txt
@@ -38,6 +38,7 @@ add_test( NAME "dcop/dcop-tests"
COMMAND sh -x "${CMAKE_CURRENT_SOURCE_DIR}/run-tests.sh"
WORKING_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}" )
+set_tests_properties( dcop/dcop-tests PROPERTIES TIMEOUT 30)
##### test.h and files ##########################