summaryrefslogtreecommitdiffstats
path: root/interfaces/kregexpeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /interfaces/kregexpeditor/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'interfaces/kregexpeditor/CMakeLists.txt')
-rw-r--r--interfaces/kregexpeditor/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/interfaces/kregexpeditor/CMakeLists.txt b/interfaces/kregexpeditor/CMakeLists.txt
index bac8b8fe1..9781763d1 100644
--- a/interfaces/kregexpeditor/CMakeLists.txt
+++ b/interfaces/kregexpeditor/CMakeLists.txt
@@ -17,4 +17,8 @@ install( FILES
##### other data ################################
-install( FILES kregexpeditor.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kregexpeditor.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)