summaryrefslogtreecommitdiffstats
path: root/interfaces/tdeimproxy/interface/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /interfaces/tdeimproxy/interface/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'interfaces/tdeimproxy/interface/CMakeLists.txt')
-rw-r--r--interfaces/tdeimproxy/interface/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/interfaces/tdeimproxy/interface/CMakeLists.txt b/interfaces/tdeimproxy/interface/CMakeLists.txt
index d62819ed8..1c722de02 100644
--- a/interfaces/tdeimproxy/interface/CMakeLists.txt
+++ b/interfaces/tdeimproxy/interface/CMakeLists.txt
@@ -18,5 +18,14 @@ install( FILES
##### other data ################################
-install( FILES kcm_instantmessenger.desktop DESTINATION ${DATA_INSTALL_DIR}/kcm_componentchooser )
-install( FILES dcopinstantmessenger.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kcm_instantmessenger.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kcm_componentchooser
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE dcopinstantmessenger.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)