summaryrefslogtreecommitdiffstats
path: root/interfaces/tdetexteditor/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /interfaces/tdetexteditor/Makefile.am
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'interfaces/tdetexteditor/Makefile.am')
-rw-r--r--interfaces/tdetexteditor/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/interfaces/tdetexteditor/Makefile.am b/interfaces/tdetexteditor/Makefile.am
new file mode 100644
index 000000000..7588019e2
--- /dev/null
+++ b/interfaces/tdetexteditor/Makefile.am
@@ -0,0 +1,52 @@
+INCLUDES = -I$(top_srcdir)/tdeio -I$(top_srcdir) -I$(top_srcdir)/interfaces -I$(top_builddir)/interfaces -I$(top_srcdir)/tdeabc -I$(top_builddir)/tdeabc $(all_includes)
+
+lib_LTLIBRARIES = libtdetexteditor.la
+
+libtdetexteditor_la_SOURCES = tdetexteditor.cpp \
+ editinterface.cpp clipboardinterface.cpp selectioninterface.cpp searchinterface.cpp \
+ codecompletioninterface.cpp wordwrapinterface.cpp blockselectioninterface.cpp \
+ configinterface.cpp cursorinterface.cpp dynwordwrapinterface.cpp \
+ printinterface.cpp highlightinginterface.cpp markinterface.cpp \
+ popupmenuinterface.cpp undointerface.cpp viewcursorinterface.cpp \
+ editdcopinterface.cpp editdcopinterface.skel clipboarddcopinterface.cpp \
+ clipboarddcopinterface.skel selectiondcopinterface.cpp selectiondcopinterface.skel \
+ searchdcopinterface.cpp searchdcopinterface.skel markinterfaceextension.cpp \
+ configinterfaceextension.cpp encodinginterface.cpp sessionconfiginterface.cpp \
+ viewstatusmsginterface.cpp editorchooser_ui.ui editorchooser.cpp \
+ blockselectiondcopinterface.cpp documentinfo.cpp documentdcopinfo.cpp\
+ blockselectiondcopinterface.skel documentdcopinfo.skel encodingdcopinterface.cpp \
+ encodingdcopinterface.skel printdcopinterface.cpp printdcopinterface.skel \
+ undodcopinterface.cpp undodcopinterface.skel viewcursordcopinterface.cpp \
+ viewcursordcopinterface.skel viewstatusmsgdcopinterface.cpp \
+ viewstatusmsgdcopinterface.skel selectioninterfaceext.cpp selectionextdcopinterface.skel \
+ texthintinterface.cpp editinterfaceext.cpp variableinterface.cpp templateinterface.cpp
+
+
+libtdetexteditor_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+libtdetexteditor_la_LIBADD = $(LIB_KPARTS) $(top_builddir)/dcop/libDCOP.la $(LIB_TDEABC) $(LIB_TDECORE) $(LIB_QT) $(LIB_TDEFILE) $(LIB_TDEUI)
+
+tdetexteditorinclude_HEADERS = document.h view.h editor.h plugin.h editinterface.h undointerface.h \
+ selectioninterface.h cursorinterface.h \
+ clipboardinterface.h popupmenuinterface.h \
+ viewcursorinterface.h searchinterface.h highlightinginterface.h \
+ blockselectioninterface.h codecompletioninterface.h \
+ configinterface.h markinterface.h printinterface.h wordwrapinterface.h \
+ dynwordwrapinterface.h markinterfaceextension.h configinterfaceextension.h \
+ encodinginterface.h viewstatusmsginterface.h sessionconfiginterface.h editorchooser.h \
+ documentinfo.h selectioninterfaceext.h selectionextdcopinterface.h texthintinterface.h \
+ editinterfaceext.h variableinterface.h templateinterface.h
+
+tdetexteditorincludedir = $(includedir)/tdetexteditor
+
+METASOURCES = AUTO
+
+servicetypedir = $(kde_servicetypesdir)
+servicetype_DATA = tdetexteditor.desktop tdetexteditoreditor.desktop tdetexteditorplugin.desktop
+
+kcm_tdetexteditor_DATA = kcm_tdetexteditor.desktop
+kcm_tdetexteditordir = $(kde_datadir)/kcm_componentchooser
+
+templateinterface.lo: $(top_builddir)/tdeabc/addressee.h
+
+include ../../admin/Doxyfile.am
+