summaryrefslogtreecommitdiffstats
path: root/kabc/formats/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kabc/formats/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kabc/formats/Makefile.am')
-rw-r--r--kabc/formats/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kabc/formats/Makefile.am b/kabc/formats/Makefile.am
new file mode 100644
index 000000000..5de6d6485
--- /dev/null
+++ b/kabc/formats/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = -I$(top_srcdir)/kabc -I$(top_builddir)/kabc $(all_includes)
+
+kde_module_LTLIBRARIES = kabcformat_binary.la
+
+kabcformat_binary_la_SOURCES = binaryformat.cpp
+kabcformat_binary_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries) \
+ -no-undefined
+kabcformat_binary_la_LIBADD = $(top_builddir)/kabc/libkabc.la
+kabcformat_binary_la_COMPILE_FIRST = $(top_builddir)/kabc/addressee.h
+
+# these are the headers for your project
+noinst_HEADERS = binaryformat.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kabcformat_binary.pot
+
+linkdir = $(kde_datadir)/kabc/formats
+link_DATA = binary.desktop
+EXTRA_DIST = $(link_DATA)