summaryrefslogtreecommitdiffstats
path: root/kate/plugins/isearch/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /kate/plugins/isearch/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'kate/plugins/isearch/CMakeLists.txt')
-rw-r--r--kate/plugins/isearch/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kate/plugins/isearch/CMakeLists.txt b/kate/plugins/isearch/CMakeLists.txt
index 38a042973..b27048597 100644
--- a/kate/plugins/isearch/CMakeLists.txt
+++ b/kate/plugins/isearch/CMakeLists.txt
@@ -27,7 +27,12 @@ link_directories(
##### other data ################################
-install( FILES tdetexteditor_isearch.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdetexteditor_isearch.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kate-desktops
+)
+
install( FILES tdetexteditor_isearchui.rc DESTINATION ${DATA_INSTALL_DIR}/tdetexteditor_isearch )