summaryrefslogtreecommitdiffstats
path: root/kate/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /kate/scripts/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'kate/scripts/CMakeLists.txt')
-rw-r--r--kate/scripts/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/kate/scripts/CMakeLists.txt b/kate/scripts/CMakeLists.txt
index 235cedd48..b01e9f1db 100644
--- a/kate/scripts/CMakeLists.txt
+++ b/kate/scripts/CMakeLists.txt
@@ -11,8 +11,14 @@
##### other data ################################
+tde_create_translated_desktop(
+ SOURCE jstest.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/katepart/scripts
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kate-desktops
+)
+
install( FILES
- jstest.desktop jstest.js script-indent-c-newline.js
+ jstest.js script-indent-c-newline.js
script-indent-c-char.js sort.js
DESTINATION ${DATA_INSTALL_DIR}/katepart/scripts )