summaryrefslogtreecommitdiffstats
path: root/kcmshell/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kcmshell/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcmshell/Makefile.am')
-rw-r--r--kcmshell/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/kcmshell/Makefile.am b/kcmshell/Makefile.am
new file mode 100644
index 000000000..81b3e2c8e
--- /dev/null
+++ b/kcmshell/Makefile.am
@@ -0,0 +1,39 @@
+#
+# Copyright (c) 1999 Matthias Hoelzer-Kluepfel <hoelzer@kde.org>
+# Copyright (c) 2000 Matthias Elter <elter@kde.org>
+# Copyright (c) 2004 Frans Englich <frans.englich@telia.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+#
+
+AM_CPPFLAGS = -I$(top_srcdir)/kutils $(all_includes)
+METASOURCES = AUTO
+
+lib_LTLIBRARIES =
+bin_PROGRAMS =
+kdeinit_LTLIBRARIES = kcmshell.la
+
+kcmshell_la_SOURCES = main.cpp main.skel
+kcmshell_la_LIBADD = ../kutils/libkutils.la
+kcmshell_la_LDFLAGS = $(all_libraries) -module -avoid-version
+
+noinst_HEADERS = main.h
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmshell.pot
+
+
+include $(top_srcdir)/admin/Doxyfile.am
+