summaryrefslogtreecommitdiffstats
path: root/kdecore/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-08-10 23:38:28 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-08-10 23:38:28 +0000
commit47ee068d2c202c4006d5a916fb2cfa4d4071230d (patch)
treeca18f62ea3a5300b4e94f757208abf47fecad42f /kdecore/CMakeLists.txt
parentdb9d51186b28bc2252032458b433ba5f8d1972bc (diff)
downloadtdelibs-47ee068d2c202c4006d5a916fb2cfa4d4071230d.tar.gz
tdelibs-47ee068d2c202c4006d5a916fb2cfa4d4071230d.zip
Add composition manager detection and support to Trinity
This adds the methods required to make transparent widgets via alpha blending a reality An additional widget class may be coming shortly git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1246265 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdecore/CMakeLists.txt')
-rw-r--r--kdecore/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/kdecore/CMakeLists.txt b/kdecore/CMakeLists.txt
index 3e37ed20c..efe2c8f3c 100644
--- a/kdecore/CMakeLists.txt
+++ b/kdecore/CMakeLists.txt
@@ -129,7 +129,7 @@ tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION 4.2.0
EMBED kdecorenetwork-static
- LINK ltdlc-static ${KDESVGICONS} DCOP-shared kdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ICE SM
+ LINK ltdlc-static ${KDESVGICONS} DCOP-shared kdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM
DEPENDENCIES dcopidl dcopidl2cpp
DESTINATION ${LIB_INSTALL_DIR}
)
@@ -199,3 +199,11 @@ tde_add_executable(kgrantpty SETUID
SOURCES kgrantpty.c
DESTINATION ${BIN_INSTALL_DIR}
)
+
+##### kdetcompmgr #################################
+
+tde_add_executable( kdetcompmgr
+ SOURCES kdetcompmgr.cpp
+ LINK kdecore-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)