summaryrefslogtreecommitdiffstats
path: root/kdesu/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kdesu/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdesu/Makefile.am')
-rw-r--r--kdesu/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/kdesu/Makefile.am b/kdesu/Makefile.am
new file mode 100644
index 000000000..211d8d422
--- /dev/null
+++ b/kdesu/Makefile.am
@@ -0,0 +1,30 @@
+## Makefile.am for libkdesu
+
+INCLUDES = -I$(top_srcdir)/kio/ $(all_includes)
+
+lib_LTLIBRARIES = libkdesu.la
+libkdesu_la_SOURCES = client.cpp process.cpp kcookie.cpp su.cpp ssh.cpp stub.cpp kdesu_pty.cpp
+libkdesu_la_LDFLAGS = -version-info 6:0:2 -no-undefined $(all_libraries)
+libkdesu_la_LIBADD = $(LIB_KDECORE) $(LIBUTIL)
+libkdesu_la_NMCHECK = $(srcdir)/libkdesu.nmcheck
+libkdesu_la_NMCHECKWEAK = $(srcdir)/libkdesu_weak.nmcheck $(top_srcdir)/kdecore/libkdecore_weak.nmcheck \
+ $(top_srcdir)/dcop/libDCOP_weak.nmcheck $(top_srcdir)/kdecore/libqt-mt_weak.nmcheck
+
+kdesudir = $(includedir)/kdesu
+kdesu_HEADERS = defaults.h client.h process.h kdesu_pty.h kcookie.h su.h ssh.h stub.h
+
+install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(kdesudir)
+ -rm -f $(DESTDIR)$(kdesudir)/pty.h
+ ln -s kdesu_pty.h $(DESTDIR)$(kdesudir)/pty.h
+
+uninstall-local:
+ -rm -f $(DESTDIR)$(kdesudir)/pty.h
+
+bin_PROGRAMS = kdesu_stub
+kdesu_stub_SOURCES = kdesu_stub.c
+kdesu_stub_LDFLAGS = $(all_libraries)
+kdesu_stub_LDADD = ../kdecore/libkdefakes.la
+
+include $(top_srcdir)/admin/Doxyfile.am
+