summaryrefslogtreecommitdiffstats
path: root/kdewidgets/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kdewidgets/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdewidgets/Makefile.am')
-rw-r--r--kdewidgets/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/kdewidgets/Makefile.am b/kdewidgets/Makefile.am
new file mode 100644
index 000000000..ee1fd209b
--- /dev/null
+++ b/kdewidgets/Makefile.am
@@ -0,0 +1,40 @@
+
+# This file is part of the KDE libraries
+# Copyright (C) 1997 Matthias Kalle Dalheimer (kalle@kde.org)
+# (C) 1997 Stephan Kulow (coolo@kde.org)
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this library; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+SUBDIRS=. pics tests
+AM_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = -I$(top_srcdir)/kfile $(all_includes)
+
+bin_PROGRAMS = makekdewidgets
+makekdewidgets_SOURCES = makekdewidgets.cpp
+makekdewidgets_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+makekdewidgets_LDADD = $(LIB_QT) ../kdecore/libkdecore.la
+
+kde_widget_LTLIBRARIES = kdewidgets.la
+kdewidgets_la_LDFLAGS = $(KDE_PLUGIN) -module $(all_libraries)
+kdewidgets_la_LIBADD = $(LIB_KIO) $(LIB_KABC)
+kdewidgets_la_SOURCES = classpreviews.cpp kdewidgets.cpp
+
+kdewidgets.cpp: $(srcdir)/kde.widgets makekdewidgets
+ ./makekdewidgets -o kdewidgets.cpp $(srcdir)/kde.widgets
+
+CLEANFILES = kdewidgets.cpp
+