summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/elf/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /kfile-plugins/elf/CMakeLists.txt
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kfile-plugins/elf/CMakeLists.txt')
-rw-r--r--kfile-plugins/elf/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/kfile-plugins/elf/CMakeLists.txt b/kfile-plugins/elf/CMakeLists.txt
deleted file mode 100644
index 91e9d5e32..000000000
--- a/kfile-plugins/elf/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-#################################################
-#
-# (C) 2012 Timothy Pearson
-# kb9vqf (AT) pearsoncomputing.net
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
- ${CMAKE_SOURCE_DIR}/tdecore
- ${CMAKE_BINARY_DIR}/tdecore
- ${CMAKE_SOURCE_DIR}/tdeui
- ${CMAKE_BINARY_DIR}/tdeui
- ${CMAKE_SOURCE_DIR}/kio/kio
- ${LIBR_INCLUDEDIR}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
- ${LIBR_LIBDIR}
-)
-
-#### other data #################################
-
-install( FILES kfile_elf.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-
-
-#### kfile_elf (module) #########################
-
-tde_add_kpart( kfile_elf AUTOMOC
- SOURCES kfile_elf.cpp
- EMBED tdelficon-static
- LINK kio-shared ${LIBR_LIBRARIES}
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)