summaryrefslogtreecommitdiffstats
path: root/kimgio/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Kent Hajnal <software@alephnull.net>2024-05-17 18:16:23 -0400
committerSlávek Banko <slavek.banko@axis.cz>2024-05-21 19:17:18 +0200
commit8414af176d732dfb8a2f93809f4361295bbfbdcb (patch)
tree1f0d1181b66195dfdc2c20b07663184eb7c0dd0c /kimgio/CMakeLists.txt
parentb74ce5928ca980e5b5a1e611404b32c22b174934 (diff)
downloadtdelibs-8414af176d732dfb8a2f93809f4361295bbfbdcb.tar.gz
tdelibs-8414af176d732dfb8a2f93809f4361295bbfbdcb.zip
Adds WebP read support to kimgio
Signed-off-by: Alex Kent Hajnal <software@alephnull.net> (cherry picked from commit 347a546d9dfb3210bcf907c3c622d6843d2ae9ce)
Diffstat (limited to 'kimgio/CMakeLists.txt')
-rw-r--r--kimgio/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/kimgio/CMakeLists.txt b/kimgio/CMakeLists.txt
index be10cf809..325f136f1 100644
--- a/kimgio/CMakeLists.txt
+++ b/kimgio/CMakeLists.txt
@@ -167,6 +167,19 @@ tde_add_kpart( ${target}
)
+##### kimg_webp #################################
+
+if( HAVE_WEBP )
+ set( target kimg_webp )
+ tde_add_kpart( ${target}
+ SOURCES webp.cpp
+ LINK tdecore-shared ${WEBP_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+ )
+ install( FILES webp.kimgio DESTINATION ${SERVICES_INSTALL_DIR} )
+endif( HAVE_WEBP )
+
+
##### other data ################################
install( FILES