summaryrefslogtreecommitdiffstats
path: root/kio/kfile/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kio/kfile/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kio/kfile/Makefile.am')
-rw-r--r--kio/kfile/Makefile.am78
1 files changed, 78 insertions, 0 deletions
diff --git a/kio/kfile/Makefile.am b/kio/kfile/Makefile.am
new file mode 100644
index 000000000..a63306189
--- /dev/null
+++ b/kio/kfile/Makefile.am
@@ -0,0 +1,78 @@
+# This file is part of the KDE libraries
+# Copyright (C) 1997 Stephan Kulow (coolo@kde.org)
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this library; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+
+INCLUDES= -I$(srcdir)/../libltdl/ -I$(top_srcdir) -I$(top_srcdir)/kdefx \
+ -I$(top_builddir)/kio/kio -I$(top_srcdir)/kio/bookmarks $(all_includes) $(LIBART_CFLAGS)
+
+noinst_LTLIBRARIES = libkfile.la
+
+METASOURCES = AUTO
+
+#SUBDIRS = . acl_prop_page
+
+include_HEADERS = kfiledialog.h kencodingfiledialog.h\
+ kdiroperator.h kfileview.h kfilefiltercombo.h \
+ kfiledetailview.h kcombiview.h kdiskfreesp.h \
+ kfileiconview.h krecentdocument.h \
+ kurlrequester.h kfilepreview.h kfile.h \
+ kurlcombobox.h kurlrequesterdlg.h kopenwith.h kpropsdlg.h \
+ kicondialog.h kdirsize.h kpreviewwidgetbase.h kimagefilepreview.h kfilesharedlg.h \
+ kfiletreeview.h kfiletreeviewitem.h kfiletreebranch.h \
+ kdirselectdialog.h kurlbar.h kpropertiesdialog.h knotifydialog.h \
+ kcustommenueditor.h knotifywidgetbase.h
+
+noinst_HEADERS = config-kfile.h krecentdirs.h kmetaprops.h \
+ kfilebookmarkhandler.h kfilemetainfowidget.h kopenwith_p.h \
+ kfilespeedbar.h kpreviewprops.h kacleditwidget.h kacleditwidget_p.h images.h
+
+libkfile_la_SOURCES = \
+ kfilefiltercombo.cpp \
+ kfileview.cpp kfileiconview.cpp \
+ krecentdocument.cpp kfiledialog.cpp kdiroperator.cpp \
+ kfiledetailview.cpp kcombiview.cpp kurlrequester.cpp \
+ kfilepreview.cpp kurlcombobox.cpp kurlrequesterdlg.cpp \
+ kopenwith.cpp kpropertiesdialog.cpp kicondialog.cpp kdirsize.cpp \
+ krecentdirs.cpp kdiskfreesp.cpp kimagefilepreview.cpp kfilesharedlg.cpp \
+ kurlbar.cpp kmetaprops.cpp kpreviewprops.cpp \
+ kfiletreeview.cpp kfiletreeviewitem.cpp kfiletreebranch.cpp \
+ kdirselectdialog.cpp kfilebookmarkhandler.cpp \
+ kfilemetainfowidget.cpp kcustommenueditor.cpp knotifywidgetbase.ui \
+ knotifydialog.cpp kfilespeedbar.cpp kpreviewwidgetbase.cpp \
+ kfilemetapreview.cpp kpropertiesdesktopbase.ui \
+ kpropertiesdesktopadvbase.ui kpropertiesmimetypebase.ui \
+ kencodingfiledialog.cpp kacleditwidget.cpp
+
+libkfile_la_COMPILE_FIRST = $(srcdir)/../kio/kdirnotify_stub.h
+
+EXTRA_DIST = NOTES
+
+# convenience lib - no _LDFLAGS or _LIBADD !
+
+servicetype_DATA = kpropsdlgplugin.desktop
+servicetypedir = $(kde_servicetypesdir)
+
+
+#Can't be a module, we need to link to it for readConfig
+#kde_module_LTLIBRARIES = libkfileshare.la
+#libkfileshare_la_SOURCES = kfileshare.cpp
+#libkfileshare_la_LIBADD = libkfile.la
+#libkfileshare_la_LDFLAGS = -module $(KDE_PLUGIN)
+#kde_services_DATA = kfilesharepropsplugin.desktop
+
+include $(top_srcdir)/admin/Doxyfile.am