summaryrefslogtreecommitdiffstats
path: root/kio/kioexec/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kio/kioexec/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kio/kioexec/Makefile.am')
-rw-r--r--kio/kioexec/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kio/kioexec/Makefile.am b/kio/kioexec/Makefile.am
new file mode 100644
index 000000000..8de01676c
--- /dev/null
+++ b/kio/kioexec/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = $(all_includes)
+
+bin_PROGRAMS = kioexec
+
+kioexec_SOURCES = main.cpp
+kioexec_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kioexec_LDADD = $(LIB_KIO)
+
+noinst_HEADERS = main.h
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) $(kioexec_SOURCES) -o $(podir)/kioexec.pot
+
+install-exec-local:
+ @rm -f $(DESTDIR)$(bindir)/kfmexec
+ @$(LN_S) kioexec $(DESTDIR)$(bindir)/kfmexec
+
+include $(top_srcdir)/admin/Doxyfile.am