summaryrefslogtreecommitdiffstats
path: root/kioslave/file/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-12 03:56:33 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-02-03 22:22:23 +0100
commitd37bb843d18966a1b2f38e49363dc9f8ebbaed43 (patch)
treefa898c1ef6d95e72c868f6f517829ce149323b69 /kioslave/file/CMakeLists.txt
parentd336392f8fd8d954754cd3e53b7e119a1f3f351b (diff)
downloadtdelibs-d37bb843d18966a1b2f38e49363dc9f8ebbaed43.tar.gz
tdelibs-d37bb843d18966a1b2f38e49363dc9f8ebbaed43.zip
Use private linking for exported CMake targets.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 158b6e1152413e4fa973b70b7469bb1f256a1f38)
Diffstat (limited to 'kioslave/file/CMakeLists.txt')
-rw-r--r--kioslave/file/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/kioslave/file/CMakeLists.txt b/kioslave/file/CMakeLists.txt
index 0462811dc..1fad97845 100644
--- a/kioslave/file/CMakeLists.txt
+++ b/kioslave/file/CMakeLists.txt
@@ -45,7 +45,6 @@ set( ${target}_SRCS
tde_add_kpart( ${target} AUTOMOC
SOURCES ${${target}_SRCS}
- LINK kio-shared
+ LINK kio-shared ${ACL_LIBRARIES}
DESTINATION ${PLUGIN_INSTALL_DIR}
)
-