summaryrefslogtreecommitdiffstats
path: root/kioslave/http/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kioslave/http/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslave/http/Makefile.am')
-rw-r--r--kioslave/http/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/kioslave/http/Makefile.am b/kioslave/http/Makefile.am
new file mode 100644
index 000000000..a29e06e9e
--- /dev/null
+++ b/kioslave/http/Makefile.am
@@ -0,0 +1,31 @@
+# $Id$
+# Makefile.am of kdebase/kioslave/http
+
+SUBDIRS = kcookiejar
+
+INCLUDES= -I$(top_srcdir)/interfaces -I$(top_srcdir)/kio/httpfilter -I$(top_srcdir)/kdecore/network $(all_includes) $(GSSAPI_INCS)
+AM_LDFLAGS = $(all_libraries) $(GSSAPI_RPATH)
+
+####### Files
+
+bin_PROGRAMS=
+lib_LTLIBRARIES=
+kdeinit_LTLIBRARIES = kio_http_cache_cleaner.la
+kde_module_LTLIBRARIES = kio_http.la
+
+kio_http_la_SOURCES = http.cc
+kio_http_la_METASOURCES = AUTO
+kio_http_la_LIBADD = $(LIB_KIO) $(top_builddir)/kio/httpfilter/libhttpfilter.la $(top_builddir)/kio/misc/kntlm/libkntlm.la
+kio_http_la_LDFLAGS = $(all_libraries) $(GSSAPI_RPATH) -module $(KDE_PLUGIN) $(GSSAPI_LIBS)
+
+kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner.cpp
+kio_http_cache_cleaner_la_LIBADD = $(LIB_KIO)
+kio_http_cache_cleaner_la_LDFLAGS = -module -avoid-version
+
+noinst_HEADERS = http.h
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = http_cache_cleaner.desktop http.protocol https.protocol \
+ webdav.protocol webdavs.protocol
+
+include $(top_srcdir)/admin/Doxyfile.am