summaryrefslogtreecommitdiffstats
path: root/kparts/tests/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
commitdfe289850f068f19ba4a83ab4e7e22a7e09c13c9 (patch)
treec297348a55df66c571de4525646e0b9762427353 /kparts/tests/Makefile.am
parentb7658a0d5eca24a9d37c6e04f88298ef02389db0 (diff)
downloadtdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.tar.gz
tdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kparts/tests/Makefile.am')
-rw-r--r--kparts/tests/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/kparts/tests/Makefile.am b/kparts/tests/Makefile.am
deleted file mode 100644
index e593cb6da..000000000
--- a/kparts/tests/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-
-INCLUDES= -I$(top_srcdir) -I$(top_srcdir)/libltdl -I$(top_srcdir)/kfile -I$(top_srcdir)/kio $(all_includes)
-AM_LDFLAGS = $(all_libraries)
-LDADD = $(LIB_KPARTS)
-
-check_PROGRAMS = kpartstest normalktmtest ghostviewtest
-
-kpartstest_SOURCES = example.cpp parts.cpp
-kpartstest_LDADD = libnotepad.la $(LIB_KPARTS)
-normalktmtest_SOURCES = normalktm.cpp parts.cpp
-normalktmtest_LDADD = libnotepad.la $(LIB_KPARTS)
-ghostviewtest_SOURCES = ghostview.cpp
-ghostviewtest_LDADD = $(LIB_KPARTS)
-
-# These are not really libraries, but modules dynamically opened.
-# So they should be installed in kde_module_dir, which is usually $prefix/lib/trinity
-kde_module_LTLIBRARIES = libspellcheckplugin.la libnotepadpart.la
-
-libspellcheckplugin_la_SOURCES = plugin_spellcheck.cpp
-libspellcheckplugin_la_LIBADD = $(LIB_KPARTS)
-libspellcheckplugin_la_LDFLAGS = -module $(KDE_PLUGIN)
-
-libnotepadpart_la_SOURCES = notepadpart.cpp
-libnotepadpart_la_LIBADD = libnotepad.la $(LIB_KPARTS)
-libnotepadpart_la_LDFLAGS = -module $(KDE_PLUGIN)
-
-noinst_LTLIBRARIES = libnotepad.la
-libnotepad_la_SOURCES = notepad.cpp
-
-rcdir = $(kde_datadir)/kpartstest
-rc_DATA = kpartstest_shell.rc
-
-testpartdir = $(kde_datadir)/kpartstestpart
-testpart_DATA = kpartstest_part1.rc
-
-notepaddir = $(kde_datadir)/notepadpart
-notepad_DATA = notepadpart.rc
-
-ghostviewtestdir = $(kde_datadir)/ghostviewtest
-ghostviewtest_DATA = ghostviewtest_shell.rc
-
-pluginsdir = $(kde_datadir)/notepadpart/kpartplugins
-plugins_DATA = plugin_foobar.rc plugin_spellcheck.rc
-
-METASOURCES = AUTO
-