summaryrefslogtreecommitdiffstats
path: root/krandr/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-04-28 01:27:24 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-04-28 01:27:24 +0000
commit3be8f38c8216094c12a7910ab09be94394a5e2db (patch)
tree70ce28e837483ef1169acdbd739d0882a3aa5b04 /krandr/Makefile.am
parent9f2307382d4acc636b621570ed7770dcab0d652a (diff)
downloadtdelibs-3be8f38c8216094c12a7910ab09be94394a5e2db.tar.gz
tdelibs-3be8f38c8216094c12a7910ab09be94394a5e2db.zip
Added new central krandr library to handle everything related to dynamic screen configuration
In the future this will probably handle ICC profiles as well This will allow easy integration of screen configuration into other KDE programs and control center modules git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1119941 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'krandr/Makefile.am')
-rw-r--r--krandr/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/krandr/Makefile.am b/krandr/Makefile.am
new file mode 100644
index 000000000..4db082a62
--- /dev/null
+++ b/krandr/Makefile.am
@@ -0,0 +1,19 @@
+
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+# For the future: examine if condensing the tons of *_LDFLAGS variables
+# into $(all_libraries) isn't better
+AM_LDFLAGS = $(LDFLAGS_AS_NEEDED) $(LDFLAGS_NEW_DTAGS)
+
+libkrandrincludedir = $(includedir)/libkrandr
+libkrandrinclude_HEADERS = randr.h lowlevel_randr.h ktimerdialog.h libkrandr.h
+
+lib_LTLIBRARIES = libkrandr.la
+libkrandr_la_SOURCES = randr.cpp lowlevel_randr.c ktimerdialog.cpp libkrandr.cc
+METASOURCES = AUTO
+
+libkrandr_la_LDFLAGS = $(KDE_MT_LDFLAGS) -version-info 0:95 -no-undefined
+libkrandr_la_LIBADD = $(LIBASOUND) ../kdecore/libkdecore.la $(LIB_QT) $(LIB_XRANDR)
+
+DOXYGEN_REFERENCES = kdecore
+include ../admin/Doxyfile.am