summaryrefslogtreecommitdiffstats
path: root/kspell2/tests/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kspell2/tests/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kspell2/tests/Makefile.am')
-rw-r--r--kspell2/tests/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/kspell2/tests/Makefile.am b/kspell2/tests/Makefile.am
new file mode 100644
index 000000000..88a0d03b6
--- /dev/null
+++ b/kspell2/tests/Makefile.am
@@ -0,0 +1,24 @@
+AM_CPPFLAGS = -DKDE_NO_COMPAT -DQT_NO_COMPAT -I$(top_srcdir)/kspell2 -I$(top_srcdir)/kspell2/ui $(all_includes)
+METASOURCES = AUTO
+
+
+check_PROGRAMS = test test_filter backgroundtest \
+ test_dialog test_highlighter test_configdialog
+
+test_SOURCES = test.cpp
+test_LDADD = ../ui/libkspell2.la $(LIB_KDECORE)
+
+test_filter_SOURCES = test_filter.cpp
+test_filter_LDADD = ../ui/libkspell2.la $(LIB_KDECORE)
+
+backgroundtest_SOURCES = backgroundtest.cpp
+backgroundtest_LDADD = ../ui/libkspell2.la $(LIB_KDECORE)
+
+test_dialog_SOURCES = test_dialog.cpp
+test_dialog_LDADD = ../ui/libkspell2.la $(LIB_KDECORE)
+
+test_highlighter_SOURCES = test_highlighter.cpp
+test_highlighter_LDADD = ../ui/libkspell2_noinst.la ../libkspell2base.la $(LIB_KDECORE)
+
+test_configdialog_SOURCES = test_configdialog.cpp
+test_configdialog_LDADD = ../ui/libkspell2_noinst.la ../libkspell2base.la $(LIB_KDECORE)