summaryrefslogtreecommitdiffstats
path: root/kspell2/ui/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kspell2/ui/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kspell2/ui/Makefile.am')
-rw-r--r--kspell2/ui/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kspell2/ui/Makefile.am b/kspell2/ui/Makefile.am
new file mode 100644
index 000000000..e5995a0aa
--- /dev/null
+++ b/kspell2/ui/Makefile.am
@@ -0,0 +1,21 @@
+METASOURCES = AUTO
+
+lib_LTLIBRARIES = libkspell2.la
+# Put most of the code in a noinst lib, for the unit tests to be able to use internal classes.
+noinst_LTLIBRARIES = libkspell2_noinst.la
+
+KDE_CXXFLAGS = -DKDE_NO_COMPAT -DQT_NO_COMPAT
+INCLUDES = -I$(top_srcdir)/kspell2 $(all_includes)
+
+kspell2includedir = $(includedir)/kspell2
+kspell2include_HEADERS = dialog.h highlighter.h configdialog.h \
+ configwidget.h
+
+libkspell2_noinst_la_SOURCES = kspell2ui.ui configwidget.cpp \
+ highlighter.cpp configui.ui configdialog.cpp
+
+dialog.lo: kspell2ui.h
+
+libkspell2_la_SOURCES = dialog.cpp
+libkspell2_la_LDFLAGS = -no-undefined -version-info 1:0:0 $(all_libraries)
+libkspell2_la_LIBADD = libkspell2_noinst.la ../libkspell2base.la