summaryrefslogtreecommitdiffstats
path: root/kutils/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
commitdfe289850f068f19ba4a83ab4e7e22a7e09c13c9 (patch)
treec297348a55df66c571de4525646e0b9762427353 /kutils/CMakeLists.txt
parentb7658a0d5eca24a9d37c6e04f88298ef02389db0 (diff)
downloadtdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.tar.gz
tdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kutils/CMakeLists.txt')
-rw-r--r--kutils/CMakeLists.txt66
1 files changed, 0 insertions, 66 deletions
diff --git a/kutils/CMakeLists.txt b/kutils/CMakeLists.txt
deleted file mode 100644
index 073ffe3a0..000000000
--- a/kutils/CMakeLists.txt
+++ /dev/null
@@ -1,66 +0,0 @@
-#################################################
-#
-# (C) 2010 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-add_subdirectory( ksettings )
-
-include_directories(
- ${TQT_INCLUDE_DIRS}
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}/tdecore
- ${CMAKE_SOURCE_DIR}
- ${CMAKE_SOURCE_DIR}/dcop
- ${CMAKE_SOURCE_DIR}/tdecore
- ${CMAKE_SOURCE_DIR}/tdeui
- ${CMAKE_SOURCE_DIR}/kio/kio
- ${CMAKE_SOURCE_DIR}/kutils
- ${CMAKE_SOURCE_DIR}/interfaces/kregexpeditor
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### headers ###################################
-
-install( FILES
- kfind.h kfinddialog.h kreplace.h kreplacedialog.h
- tdecmoduleinfo.h tdecmoduleloader.h kcmultidialog.h
- kmultitabbar.h kplugininfo.h tdecmoduleproxy.h
- kpluginselector.h tdecmodulecontainer.h
- DESTINATION ${INCLUDE_INSTALL_DIR} )
-
-
-##### other data ################################
-
-install( FILES kplugininfo.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
-
-
-#### kutils #####################################
-
-set( target kutils )
-
-set( ${target}_SRCS
- kfind.cpp kfinddialog.cpp kreplace.cpp
- kreplacedialog.cpp tdecmoduleinfo.cpp tdecmoduleloader.cpp
- kcmultidialog.cpp kmultitabbar.cpp kplugininfo.cpp
- tdecmoduleproxy.cpp kpluginselector.cpp tdecmodulecontainer.cpp
- tdecmoduleproxyIface.skel tdecmoduleproxyIfaceImpl.cpp
-)
-
-tde_add_library( ${target} SHARED AUTOMOC
- SOURCES ${${target}_SRCS}
- VERSION 1.2.0
- EMBED ksettings-static
- LINK kparts-shared
- DESTINATION ${LIB_INSTALL_DIR}
- DEPENDENCIES dcopidl
-)