summaryrefslogtreecommitdiffstats
path: root/mimetypes/application/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /mimetypes/application/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'mimetypes/application/CMakeLists.txt')
-rw-r--r--mimetypes/application/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/mimetypes/application/CMakeLists.txt b/mimetypes/application/CMakeLists.txt
index 7611148bd..b2c226bcc 100644
--- a/mimetypes/application/CMakeLists.txt
+++ b/mimetypes/application/CMakeLists.txt
@@ -11,7 +11,7 @@
##### other data ################################
-install( FILES
+foreach( _mimetype
x-dvi.desktop x-gzdvi.desktop x-bz2dvi.desktop
x-tex-gf.desktop x-gzip.desktop x-pak.desktop
x-object.desktop x-tex-pk.desktop pdf.desktop
@@ -103,7 +103,13 @@ install( FILES
vnd.ms-powerpoint.template.macroEnabled.12.desktop
vnd.ms-powerpoint.slideshow.macroEnabled.12.desktop
x-lzma.desktop x-tlzma.desktop x-lzip.desktop x-tlz.desktop x-txz.desktop x-xz.desktop
- DESTINATION ${MIME_INSTALL_DIR}/application )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_mimetype}
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/mimetypes
+ )
+endforeach()
install( FILES uninstall.desktop DESTINATION ${MIME_INSTALL_DIR}/application RENAME x-applix.desktop )
install( FILES uninstall.desktop DESTINATION ${MIME_INSTALL_DIR}/application RENAME x-oowriter.desktop )