summaryrefslogtreecommitdiffstats
path: root/mimetypes/multipart/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /mimetypes/multipart/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'mimetypes/multipart/CMakeLists.txt')
-rw-r--r--mimetypes/multipart/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/mimetypes/multipart/CMakeLists.txt b/mimetypes/multipart/CMakeLists.txt
index 02ed296f5..186c13b68 100644
--- a/mimetypes/multipart/CMakeLists.txt
+++ b/mimetypes/multipart/CMakeLists.txt
@@ -11,7 +11,12 @@
##### other data ################################
-install( FILES
+foreach( _mimetype
mixed.desktop x-mixed-replace.desktop
- DESTINATION ${MIME_INSTALL_DIR}/multipart )
-
+)
+ tde_create_translated_desktop(
+ SOURCE ${_mimetype}
+ DESTINATION ${MIME_INSTALL_DIR}/multipart
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/mimetypes
+ )
+endforeach()