summaryrefslogtreecommitdiffstats
path: root/pics/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /pics/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'pics/Makefile.am')
-rw-r--r--pics/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/pics/Makefile.am b/pics/Makefile.am
new file mode 100644
index 000000000..9112b1620
--- /dev/null
+++ b/pics/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = . hicolor crystalsvg emoticons
+
+INCLUDES = $(LIBART_CFLAGS) -I$(top_srcdir)/kdecore/svgicons -I$(top_srcdir)/kdefx $(all_includes)
+
+if include_SVGICONS
+KSVGTOPNG=ksvgtopng
+endif
+
+bin_PROGRAMS = $(KSVGTOPNG)
+
+ksvgtopng_SOURCES = ksvgtopng.cpp
+ksvgtopng_LDADD = $(LIBART_LIBS) $(LIB_KDECORE) $(top_builddir)/kdecore/svgicons/libkdesvgicons.la
+ksvgtopng_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+install-data-local:
+ -rm -f $(DESTDIR)$(kde_icondir)/default.kde
+ $(mkinstalldirs) $(DESTDIR)$(kde_icondir)
+ $(LN_S) crystalsvg $(DESTDIR)$(kde_icondir)/default.kde