summaryrefslogtreecommitdiffstats
path: root/tdeabc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdeabc/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeabc/CMakeLists.txt')
-rw-r--r--tdeabc/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/tdeabc/CMakeLists.txt b/tdeabc/CMakeLists.txt
index fabfa2e3e..54870047c 100644
--- a/tdeabc/CMakeLists.txt
+++ b/tdeabc/CMakeLists.txt
@@ -59,8 +59,18 @@ install( FILES
##### other data ################################
-install( FILES tdeab2tdeabc.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
-install( FILES tdeabc_manager.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources )
+tde_create_translated_desktop(
+ SOURCE tdeab2tdeabc.desktop
+ DESTINATION ${AUTOSTART_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeabc-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE tdeabc_manager.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeabc-desktops
+)
+
install( FILES countrytransl.map DESTINATION ${DATA_INSTALL_DIR}/tdeabc )